VSTO Word application finally deployed

Well, I finally got around to sorting our the deployment of my VSTO2005 Word application. After trying unsuccessfully to build a windows installer to take care of installing the prerequisite .NET 2.0 Framework, Primary Interop assemblies and VSTO2005 runtime along with the Word application I followed some guidance from MS. The final solution I am now using is to provide the installers for the prerequisites with some instructions for installing them and deploy the Word application to a file server with instructions regarding how to grant the associated assembly permission to run on the users system.
Initial pilot feedback has been good. I now have to sort out a couple of minor issues with the solution before I release it as the production version. I am intercepting the save event in Word and removing the customisations so that a saved document can be distributed to interested parties. When the documet is re-opened I receive a message regarding a missing XML expansion pack. If you click ok the message goes away. If you then save the document and open it again the message nolonger appears. I just need to stop this happening and it will be fininshed.
Advertisements

Leave a comment

Filed under Uncategorized

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s